summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2016-12-03 11:11:48 -0500
committerAllen Winter <allen.winter@kdab.com>2016-12-03 11:11:48 -0500
commitf70a26aaf836da0f9e242945151b49190d682d95 (patch)
treebae113e5c1eb9bd04fb7dacebb9120a857a97ae5 /CMakeLists.txt
parent50720ff856913827242100ac5acd37e0362eca5e (diff)
downloadlibical-git-f70a26aaf836da0f9e242945151b49190d682d95.tar.gz
CMakeLists.txt, libical.pc.in - ICU must appear as Requires in pkgconfig
issue#244
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3d49d0d..0f6dfc34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -145,7 +145,7 @@ endif()
# RSCALE info at http://tools.ietf.org/html/rfc7529
find_package(ICU)
if(ICU_FOUND)
- set(ICUUC_LIBS "-licuuc") #for libical.pc
+ set(REQUIRES_PRIVATE_ICU "Requires.private: icu-i18n") #for libical.pc
set(HAVE_LIBICU 1)
if(ICU_MAJOR_VERSION VERSION_GREATER 50)
set(HAVE_ICU_DANGI TRUE)
@@ -155,7 +155,6 @@ if(ICU_FOUND)
endif()
if(ICU_I18N_FOUND)
set(HAVE_LIBICU_I18N 1)
- set(ICUI18N_LIBS "-licui18n") #for libical.pc
endif()
# MSVC specific definitions