summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2017-06-03 18:40:22 -0400
committerAllen Winter <allen.winter@kdab.com>2017-06-03 18:40:22 -0400
commit84a482e56ba5a26522d7e6de0626f2292c4d79d1 (patch)
tree6129f2d60d926ceba84a2dee9c63c8f53e3044d8 /doc/CMakeLists.txt
parent520dc0afcee01e4ce8eea9620821e6dc5867c118 (diff)
downloadlibical-git-84a482e56ba5a26522d7e6de0626f2292c4d79d1.tar.gz
doc/CMakeLists.txt - add set_package_properties for doxygen
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index ac52f39c..596ad989 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -11,6 +11,12 @@ macro(_join_list _var _sep)
endmacro()
find_package(Doxygen)
+set_package_properties(Doxygen PROPERTIES
+ TYPE OPTIONAL
+ DESCRIPTION "API Documentation system"
+ URL "http://www.doxygen.org"
+ PURPOSE "Needed to build the API documention."
+)
if(DOXYGEN_FOUND)
file(GLOB _dox_deps *.dox *.html)
file(GLOB _all_hdrs