summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 462a52f1..d31b325e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,7 @@
#
# -DSTATIC_ONLY=[true|false]
# Set to build static libraries only.
-# Turns-off GObject Introspection.
+# Not available for GObject Introspection and Vala "vapi"
# Default=false (build shared and static libs)
#
# -DSHARED_ONLY=[true|false]
@@ -406,6 +406,14 @@ add_feature_info(
"build Vala \"vapi\" files"
)
if(ICAL_GLIB_VAPI)
+ if(STATIC_ONLY)
+ message(FATAL_ERROR
+ "You are attempting to build the Vala api, however that option is not supported "
+ "when building static libraries only. "
+ "Please disable the static only option (-DSTATIC_ONLY=False) "
+ "if you really want to build the Vala api. Alternatively, "
+ "you can disable this feature (by passing -DICAL_GLIB_VAPI=False to cmake).")
+ endif()
if(NOT GOBJECT_INTROSPECTION)
message(FATAL_ERROR
"You requested to build the Vala vapi but have not enabled the GObject Introspection. "