summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2013-05-04 21:39:27 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2013-05-04 21:39:27 +0000
commitfec6336699f34758d3e6cb41b2edf902fedb9035 (patch)
tree8256c1dbf3ca7c9e58a3dbecf07cf826fb2e0ce2 /examples/CMakeLists.txt
parent7dbffd7e2b0067e834801617c5c486e3177f6709 (diff)
downloadlibical-master.tar.gz
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt42
1 files changed, 8 insertions, 34 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 441d387..3379ffd 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,49 +1,23 @@
include_directories(
- ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
${CMAKE_SOURCE_DIR}/src ${CMAKE_BINARY_DIR}/src
- ${CMAKE_SOURCE_DIR}/src/libical ${CMAKE_BINARY_DIR}/src/libical
+ ${CMAKE_SOURCE_DIR}/src/libical ${CMAKE_BINARY_DIR}/src/libical
${CMAKE_SOURCE_DIR}/src/libicalss ${CMAKE_BINARY_DIR}/src/libicalss
)
########### next target ###############
-SET(doesnothing_SRCS
- access_components.c
- access_properties_and_parameters.c
- errors.c
- main.c
- parse_text.c
+set(doesnothing_SRCS
+ access_components.c
+ access_properties_and_parameters.c
+ errors.c
+ main.c
+ parse_text.c
)
add_executable(doesnothing ${doesnothing_SRCS})
target_link_libraries(doesnothing ical icalss icalvcal ical icalss icalvcal)
-
########### install files ###############
-
-
-
-#original Makefile.am contents follow:
-
-#
-#noinst_PROGRAMS = doesnothing
-#
-#if WITH_BDB4
-#doesnothing_LDADD = ../src/libical/libical.la ../src/libicalss/libicalss.la ../src/libicalvcal/libicalvcal.la @BDB_DIR_LIB@/@BDB_LIB@
-#else
-#doesnothing_LDADD = ../src/libical/libical.la ../src/libicalss/libicalss.la ../src/libicalvcal/libicalvcal.la
-#endif
-#
-#LIBS = @PTHREAD_LIBS@
-#
-#INCLUDES = -I. -I../src -I../src/libical -I$(srcdir)/../src/libical -I../src/libicalss -I../src/libicalvcal
-#
-#doesnothing_SOURCES = \
-# access_components.c \
-# access_properties_and_parameters.c \
-# errors.c \
-# main.c \
-# parse_text.c
-#