summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2021-09-10 15:02:37 +0200
committerAleksander Morgado <aleksander@aleksander.es>2021-09-13 09:35:08 +0200
commit2e6edfc1ef58003fba2bc771dc7f82e6421566c4 (patch)
tree97c640380a9bb03ced083ed9ce41628aefcc627c /meson.build
parent28dc34931780e206342be576f3f6745428b6dc08 (diff)
downloadlibmbim-2e6edfc1ef58003fba2bc771dc7f82e6421566c4.tar.gz
build: Create a variable for the project name
A new variable called `mbim_name` has been created to avoid the call to a function inside the meson object.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1391c94..ea2c828 100644
--- a/meson.build
+++ b/meson.build
@@ -13,6 +13,7 @@ project(
meson_version: '>= 0.53.0',
)
+mbim_name = meson.project_name()
mbim_version = meson.project_version()
version_array = mbim_version.split('.')
mbim_major_version = version_array[0].to_int()
@@ -26,7 +27,7 @@ mbim_includedir = get_option('includedir')
mbim_libexecdir = get_option('libexecdir')
mbim_mandir = get_option('mandir')
-mbim_glib_include_subdir = meson.project_name() + '-glib'
+mbim_glib_include_subdir = mbim_name + '-glib'
mbim_glib_pkgincludedir = join_paths(mbim_includedir, mbim_glib_include_subdir)
# libtool versioning for libmbim-glib (-version-info c:r:a)