summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Aker <brian@tangent.org>2014-02-16 01:06:40 -0800
committerBrian Aker <brian@tangent.org>2014-02-16 01:06:40 -0800
commitf2a59b728c20f7fe78874dd41187ab3fb2db6c7e (patch)
tree0eb8f025a8916f509ede181662ae66a544ae49cd /Makefile.am
parentdbc62573e1a6dc8cbcc97d0898e8615b0916d6ab (diff)
downloadlibmemcached-f2a59b728c20f7fe78874dd41187ab3fb2db6c7e.tar.gz
Fix for building docs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 895debbc..e8a4121c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,10 @@ EXTRA_DIST=
dist_man_MANS=
MAINTAINERCLEANFILES=
+if IS_VCS_CHECKOUT
+SUBDIRS= docs
+endif
+
#includes additional rules from aminclude.am
@INC_AMINCLUDE@
@@ -57,7 +61,7 @@ endif
include libmemcachedutil-1.0/include.am
include clients/include.am
-include docs/include.am
+
include man/include.am
if BUILD_LIBMEMCACHED_PROTOCOL
@@ -103,7 +107,7 @@ merge-clean:
@echo "Files that need to be either removed or checked in:"
@bzr unknowns
-clean-local: clean-libtest-check clean-docs-check clean-rpm
+clean-local: clean-libtest-check clean-rpm
lcov: lcov-clean check
@@ -125,10 +129,7 @@ DISTCLEANFILES+= config/top.h
maintainer-clean-local:
find . -type f -name '*~' -exec rm -f '{}' \;
- -rm -f man/*.1
- -rm -f man/*.3
- -rm -f man/*.8
- -rm -rf man/.doctrees/
+ -$(RM) $(dist_man_MANS)
-rm -f Makefile.in
-rm -f aclocal.m4
-rm -f build-aux/compile