summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2008-07-18 14:57:36 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2008-07-18 14:57:36 +0000
commitd1e80dc431815df3ac6eeed654eeccaf8d6beea7 (patch)
treecc8b20e9558f81920c490fe4ec1384c8b7a0662b /doc/Makefile.am
downloadlibmpeg2-tarball-d1e80dc431815df3ac6eeed654eeccaf8d6beea7.tar.gz
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..797cb7b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,20 @@
+AM_CFLAGS = $(MPEG2DEC_CFLAGS)
+
+libmpeg2 = $(top_builddir)/libmpeg2/libmpeg2.la
+libmpeg2convert = $(top_builddir)/libmpeg2/convert/libmpeg2convert.la
+
+noinst_PROGRAMS = sample1 sample2 sample3 sample4 sample5 sample6
+sample1_SOURCES = sample1.c
+sample1_LDADD = $(libmpeg2)
+sample2_SOURCES = sample2.c
+sample2_LDADD = $(libmpeg2) $(libmpeg2convert)
+sample3_SOURCES = sample3.c
+sample3_LDADD = $(libmpeg2)
+sample4_SOURCES = sample4.c
+sample4_LDADD = $(libmpeg2) $(libmpeg2convert)
+sample5_SOURCES = sample5.c
+sample5_LDADD = $(libmpeg2)
+sample6_SOURCES = sample6.c
+sample6_LDADD = $(libmpeg2) $(libmpeg2convert)
+
+EXTRA_DIST = libmpeg2.txt