summaryrefslogtreecommitdiff
path: root/libmpeg2/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2008-07-18 14:57:36 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2008-07-18 14:57:36 +0000
commitd1e80dc431815df3ac6eeed654eeccaf8d6beea7 (patch)
treecc8b20e9558f81920c490fe4ec1384c8b7a0662b /libmpeg2/Makefile.am
downloadlibmpeg2-tarball-master.tar.gz
Diffstat (limited to 'libmpeg2/Makefile.am')
-rw-r--r--libmpeg2/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/libmpeg2/Makefile.am b/libmpeg2/Makefile.am
new file mode 100644
index 0000000..a4dd944
--- /dev/null
+++ b/libmpeg2/Makefile.am
@@ -0,0 +1,24 @@
+SUBDIRS = convert
+
+AM_CFLAGS = $(OPT_CFLAGS) $(LIBMPEG2_CFLAGS)
+
+lib_LTLIBRARIES = libmpeg2.la
+libmpeg2_la_SOURCES = alloc.c header.c decode.c slice.c motion_comp.c idct.c
+libmpeg2_la_LIBADD = libmpeg2arch.la
+libmpeg2_la_LDFLAGS = -no-undefined -version-info 1:0:1
+
+noinst_LTLIBRARIES = libmpeg2arch.la
+libmpeg2arch_la_SOURCES = motion_comp_mmx.c idct_mmx.c \
+ motion_comp_altivec.c idct_altivec.c \
+ motion_comp_alpha.c idct_alpha.c \
+ motion_comp_vis.c motion_comp_arm.c \
+ cpu_accel.c cpu_state.c
+if ARCH_ARM
+libmpeg2arch_la_SOURCES += motion_comp_arm_s.S
+endif
+libmpeg2arch_la_CFLAGS = $(OPT_CFLAGS) $(ARCH_OPT_CFLAGS) $(LIBMPEG2_CFLAGS)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libmpeg2.pc
+
+EXTRA_DIST = vlc.h mpeg2_internal.h