summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJoachim Nilsson <troglobit@gmail.com>2019-10-15 21:01:52 +0200
committerJoachim Nilsson <troglobit@gmail.com>2019-10-15 21:01:52 +0200
commitb796e3bd8da504afa2bad17ad0c4b0d620fe1025 (patch)
tree99ba08918cb355cf927d93ea3c620686eebffe00 /doc/Makefile.am
parent3eb53ad1c2fe171869705f278d38fe579c31ad60 (diff)
downloadlibnet-b796e3bd8da504afa2bad17ad0c4b0d620fe1025.tar.gz
Automate building of doc both from GIT and dist tarball
From both GIT and dist tarball: - Build html and man automatically if enabled and doxygen is available - Install html and man if enabled and built successfully, skip otherwise Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 255c143..203497e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -7,6 +7,11 @@ DISTCLEANFILES = libnet.tag
if ENABLE_HTML
pkgdata_DATA = html/*
+all-local: doc
+
clean-local:
-rm -rf html
+
+doc:
+ $(MAKE) -C @top_builddir@ $@
endif