summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-06-16 03:54:28 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-06-16 03:56:56 +0530
commit9637c1fd842dae1141b2ff9a989fedcf456d16f3 (patch)
tree498ce555eb18a0f750085ff54b059af296b56101 /meson.build
parent165086e89793867e7c638250c5fc8cbc81bd7328 (diff)
downloadlibnice-9637c1fd842dae1141b2ff9a989fedcf456d16f3.tar.gz
meson: Fix typos in crypto-library detection
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 39a289a..9bac451 100644
--- a/meson.build
+++ b/meson.build
@@ -189,7 +189,7 @@ gthread_dep = dependency('gthread-2.0',
# Cryto library
opt_cryptolib = get_option('crypto-library')
-message('Crypto librar requested: ' + opt_cryptolib)
+message('Crypto library requested: ' + opt_cryptolib)
if opt_cryptolib != 'openssl'
crypto_dep = dependency('gnutls', version: gnutls_req, required: false)
cdata.set('HAVE_GNUTLS', crypto_dep.found())
@@ -243,7 +243,7 @@ endif
if not crypto_dep.found()
if opt_cryptolib == 'gnutls'
error('GnuTLS requested as crypto library, but not found')
- elif opt_cryptolib == 'gnutls'
+ elif opt_cryptolib == 'openssl'
error('OpenSSL requested as crypto library, but not found')
else
error('Either GnuTLS or OpenSSL is required as crypto library, but neither was found')