summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index ce2e2d6..c161503 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -68,7 +68,11 @@ foreach tname : nice_tests
endif
endforeach
-if gst_dep.found()
+# FIXME: The GStreamer test needs nicesrc and nicesink plugins to run. libnice might be part of the GStreamer build.
+# In this case, in static mode (gstreamer-full), the test should be built after gstreamer-full to initialize
+# properly the plugins (gstreamer and libnice ones) with gst_init_static_plugins.
+# That's the reason the test is now disabled in static mode.
+if gst_dep.found() and not static_build
gst_check = dependency('gstreamer-check-1.0', required: get_option('gstreamer'),
fallback : ['gstreamer', 'gst_check_dep'])
if gst_check.found()