summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am24
1 files changed, 16 insertions, 8 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 0dd044b..dc52163 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,17 +1,25 @@
# -*- Makefile -*-
-.PHONY: gendoc
+.PHONY: gendoc api_refs asciidoc
-ASCIIDOCOPTS=-n -a pygments -a toc -a language=c -a icons \
+ASCIIDOCOPTS=-a pygments -a language=c -a icons \
-a imagesdir="images/" \
-a stylesdir="${abs_srcdir}/stylesheets/"
-gendoc:
+%.html: %.txt
+ asciidoc $(ASCIIDOCOPTS) $<
+ ./doxygen-link.py libnl.dict $@ > doxygen-link.tmp
+ mv doxygen-link.tmp $@
+
+asciidoc: core.html route.html index.html link.html
+
+api_ref:
doxygen Doxyfile;
./gen-tags.sh | ./tags2dict.sh > libnl.dict
- asciidoc $(ASCIIDOCOPTS) core.txt
- ./doxygen-link.py libnl.dict core.html > core.tmp.html
- mv core.tmp.html core.html
-distclean-local:
- rm -f api/* libnl.tags *.html;
+gendoc:
+ $(MAKE) api_ref
+ $(MAKE) asciidoc
+
+clean-local:
+ rm -f api/* libnl.dict *.html;