summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLorry <lorry@roadtrain.codethink.co.uk>2012-07-18 21:33:10 +0100
committerLorry <lorry@roadtrain.codethink.co.uk>2012-07-18 21:33:10 +0100
commitf4ded6a75809a84e330e7f3b66436bd2ea2c9974 (patch)
tree92880c33d016fcbf463766b59450e2a3eb9e8838 /Makefile.am
downloadliboauth-f4ded6a75809a84e330e7f3b66436bd2ea2c9974.tar.gz
Tarball conversion
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..bacc32a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,39 @@
+ACLOCAL_AMFLAGS= -I m4
+SUBDIRS = @subdirs@
+
+EXTRA_DIST=liboauth.lsm.in oauth.pc.in Doxyfile.in \
+ COPYING.GPL COPYING.MIT LICENSE.OpenSSL \
+ m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = oauth.pc
+
+TESTS=tests/tcwiki@EXESUF@ tests/tceran@EXESUF@ tests/tcother@EXESUF@
+
+CLEANFILES = stamp-doxygen stamp-doc
+
+MAINTAINERCLEANFILES = \
+ src/Makefile.in \
+ tests/Makefile.in \
+ tests/atconfig \
+ doc/Makefile.in \
+ Makefile.in \
+ aclocal.m4 \
+ compile \
+ config.guess \
+ config.h.in \
+ config.sub \
+ configure \
+ depcomp \
+ install-sh \
+ missing
+
+dox: stamp-doxygen
+
+stamp-doxygen: src/oauth.h doc/mainpage.dox
+ $(DOXYGEN) Doxyfile && touch stamp-doxygen
+ cp doc/man/man3/oauth.h.3 doc/oauth.3
+ sed 's/ -\([qsdU]\)/ \\-\1/g' doc/man/man3/oauth.h.3 \
+ | sed 's/ -1 / \\-1 /' \
+ | sed 's/--/\\-\\-/' \
+ > doc/oauth.3