summaryrefslogtreecommitdiff
path: root/testsuite/instruction/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/instruction/Makefile.am')
-rw-r--r--testsuite/instruction/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/testsuite/instruction/Makefile.am b/testsuite/instruction/Makefile.am
new file mode 100644
index 0000000..804d643
--- /dev/null
+++ b/testsuite/instruction/Makefile.am
@@ -0,0 +1,15 @@
+
+noinst_PROGRAMS = list-impls
+
+noinst_DATA = report
+
+AM_LDFLAGS = $(LIBOIL_LIBS)
+AM_CFLAGS = $(LIBOIL_CFLAGS)
+
+
+report: list-impls
+ ./check-instructions.pl $(top_builddir)/liboil/.libs/liboiltmp1.so >report
+
+
+EXTRA_CLEAN = report
+