summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDenis Ovsienko <denis@ovsienko.info>2021-08-03 22:34:14 +0100
committerDenis Ovsienko <denis@ovsienko.info>2021-08-03 22:37:05 +0100
commit815b367d5bafe2bebcc0aa6ff8f54f21c4efafc5 (patch)
tree03fbe3aeba18c799d47f375f2b6edf85e706ef27 /CMakeLists.txt
parent7af4a693ee1cd6b87ecf89972b202039378a5c48 (diff)
downloadlibpcap-815b367d5bafe2bebcc0aa6ff8f54f21c4efafc5.tar.gz
CMake: Fix EXTRA_CFLAGS after commit 29d7856. [skip appveyor]
check_and_add_compiler_option() takes a string, not a variable. Get it right this time and run CMake builds with a warnings guard again.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 388edd20..fdd91800 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2060,7 +2060,7 @@ endif(NOT MSVC)
#
if(NOT "${EXTRA_CFLAGS}" STREQUAL "")
foreach(_extra_cflag ${EXTRA_CFLAGS})
- check_and_add_compiler_option(_extra_cflag)
+ check_and_add_compiler_option("${_extra_cflag}")
endforeach(_extra_cflag)
message(STATUS "Added extra compile options (${EXTRA_CFLAGS})")
endif()