summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2016-08-13 21:23:42 -0500
committerGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2016-08-13 21:23:42 -0500
commit39df0ced1893caa2d2ee36f422200dfd49cc50a0 (patch)
tree3fd43f31364a462396ea4493cfb5271ebeead0c9 /Makefile.am
parent2705f55221073b837eeab0dd5fe05337689ee773 (diff)
downloadlibpng-39df0ced1893caa2d2ee36f422200dfd49cc50a0.tar.gz
[libpng16] Don't install pngcp; it conflicts with pngcp in the pngtools package.
Moved it from bin_PROGRAMS to check_PROGRAMS in Makefile.am so it will be built but not installed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 39e9bdeed..74ca36b10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,13 +12,13 @@ PNGLIB_BASENAME= libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@
ACLOCAL_AMFLAGS = -I scripts
# test programs - run on make check, make distcheck
-check_PROGRAMS= pngtest pngunknown pngstest pngvalid pngimage
+check_PROGRAMS= pngtest pngunknown pngstest pngvalid pngimage pngcp
if HAVE_CLOCK_GETTIME
check_PROGRAMS += timepng
endif
# Utilities - installed
-bin_PROGRAMS= pngcp pngfix png-fix-itxt
+bin_PROGRAMS= pngfix png-fix-itxt
# This ensures that pnglibconf.h gets built at the start of 'make all' or
# 'make check', but it does not add dependencies to the individual programs,