summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosmin Truta <ctruta@gmail.com>2019-04-21 00:30:14 -0400
committerCosmin Truta <ctruta@gmail.com>2019-04-21 00:30:14 -0400
commit72fa126446460347a504f3d9b90f24aed1365595 (patch)
treef35f1a33a94da387070c247f115c6b1ad0733d21 /Makefile.am
parent5df8e982e2bad2af7da5ecf689219ca89296c56d (diff)
downloadlibpng-72fa126446460347a504f3d9b90f24aed1365595.tar.gz
Avoid random test failures by running pngtest sequentially only
It is unreliable to run pngtest in parallel, due to competing writes to the same intermediate/output file ("pngout.png"). Customization of this output file name should be possible, but it is currently broken.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f621aa4d..f21107e65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,8 +59,7 @@ pngcp_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
# Generally these are single line shell scripts to run a test with a particular
# set of parameters:
TESTS =\
- tests/pngtest\
- tests/pngtest-badpngs\
+ tests/pngtest-all\
tests/pngvalid-gamma-16-to-8 tests/pngvalid-gamma-alpha-mode\
tests/pngvalid-gamma-background tests/pngvalid-gamma-expand16-alpha-mode\
tests/pngvalid-gamma-expand16-background\