summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2013-05-08 19:46:10 -0500
committerGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2013-05-08 19:46:10 -0500
commitff141eb21e5515729225251c29c441c2a69a5f3d (patch)
treefd3418b96e63606f64304b0ba54b45b201e5e507 /Makefile.am
parent122bec17f21fa84cdaccb30b4eed754f05afa349 (diff)
downloadlibpng-ff141eb21e5515729225251c29c441c2a69a5f3d.tar.gz
[libpng16] Renamed contrib/tools/fixitxt to contrib/tools/png-fix-itxt.
Added information in the documentation about problems with and fixes for the bad CRC and bad iTXt chunk situations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b1f9edf4..1d27b1140 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@ ACLOCAL_AMFLAGS = -I scripts
check_PROGRAMS= pngtest pngunknown pngstest pngvalid
# Utilities - installed
-bin_PROGRAMS= pngdeflate fixitxt
+bin_PROGRAMS= pngdeflate png-fix-itxt
pngtest_SOURCES = pngtest.c
pngtest_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
@@ -27,7 +27,7 @@ pngunknown_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
pngdeflate_SOURCES = contrib/tools/pngdeflate.c
pngdeflate_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
-fixitxt_SOURCES = contrib/tools/fixitxt.c
+png_fix_itxt_SOURCES = contrib/tools/png-fix-itxt.c
# Generally these are single line shell scripts to run a test with a particular
# set of parameters:
@@ -196,7 +196,7 @@ $(srcdir)/scripts/pnglibconf.h.prebuilt:
# an installed one (this can happen immediately after on a clean system if
# 'make test' is the first thing the user does.)
pngstest.o pngvalid.o pngtest.o pngunknown.o timepng.o: pnglibconf.h
-pngdeflate.o fixitxt.o: pnglibconf.h
+pngdeflate.o png-fix-itxt.o: pnglibconf.h
# We must use -DPNG_NO_USE_READ_MACROS here even when the library may actually
# be built with PNG_USE_READ_MACROS; this prevents the read macros from