summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorjbj <jbj>1999-10-25 18:22:19 +0000
committerjbj <jbj>1999-10-25 18:22:19 +0000
commit2afbbdf4e0a340113b11d50d187eeceecc68f5d3 (patch)
tree4067718645fe62f9ff99069a4882f56fea152947 /Makefile.am
parentf1e880039cfa3654c8edae03961023d4f924248e (diff)
downloadlibpopt-2afbbdf4e0a340113b11d50d187eeceecc68f5d3.tar.gz
Add !#:+ token parsing to retrieve (and delete) next argument from list.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c0aca77..ce9d5e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,25 +2,27 @@
AUTOMAKE_OPTIONS = 1.4 foreign
-EXTRA_DIST = CHANGES autogen.sh findme.h $(man_MANS) popt.spec poptint.h \
+EXTRA_DIST = CHANGES autogen.sh $(man_MANS) popt.spec \
testit.sh po/Makefile.in.in po/POTFILES.in po/*.po po/popt.pot popt.ps
SUBDIRS = intl po
INCLUDES = -I$(top_srcdir)
-noinst_INCLUDES = findme.h poptint.h
+noinst_HEADERS = findme.h poptint.h system.h
noinst_PROGRAMS = test1 test2
test1_SOURCES = test1.c
+test1_LDFLAGS = -all-static
test1_LDADD = $(lib_LTLIBRARIES)
test2_SOURCES = test2.c
+test2_LDFLAGS = -all-static
test2_LDADD = $(lib_LTLIBRARIES)
noinst_SCRIPTS = testit.sh
TESTS_ENVIRONMENT = \
-test1="`pwd`/.libs/lt-test1"
+test1="./test1"
TESTS = testit.sh