summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordevzero2000 <devzero2000>2010-06-29 10:47:57 +0000
committerdevzero2000 <devzero2000>2010-06-29 10:47:57 +0000
commit4d28f2e36ea29bca5016ff319897935fb384e9fa (patch)
tree56e2675fb9ffe480576330201e81f2eac14937aa /Makefile.am
parentaecec9664fec5bba86639296a9c41ef8be946c49 (diff)
downloadlibpopt-4d28f2e36ea29bca5016ff319897935fb384e9fa.tar.gz
A bunch of minor fix
- redo configure.ac and Makefile.am with different auto, probably to refine the ugly check command with some m4 macro. - add LINGUAS in favor of ALL_LINGUAS in autogen.sh and Makefile.am - fixup aix portability issue with alloca(system.h and configure.ac) and native compiler : make check work also - keep make dist and distcheck working
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am62
1 files changed, 36 insertions, 26 deletions
diff --git a/Makefile.am b/Makefile.am
index 0b3a15e..4afa610 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,9 +3,6 @@
ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = -I. -I$(top_srcdir)
-LINT = splint
-MCCABE = pmccabe
-
EXTRA_DIST = lookup3.c autogen.sh CHANGES \
footer_no_timestamp.html libpopt.vers \
$(TESTS) test-poptrc\
@@ -50,37 +47,36 @@ endif
dist_man_MANS = popt.3
-BUILT_SOURCES = popt.pc # popt.lcd
+BUILT_SOURCES = popt.pc
distclean-local:
- rm -rf .ccache
-
-.PHONY: updatepo
-updatepo:
- rsync -Lrtvz translationproject.org::tp/latest/popt/ po
-
-popt.lcd: Makefile.am ${libpopt_la_SOURCES} ${include_HEADERS} ${noinst_HEADERS}
- lclint -dump $@ ${libpopt_la_SOURCES}
+ rm -rf .ccache
-.PHONY: sources
-sources:
- @echo $(libpopt_la_SOURCES:%=popt/%)
+clean-local:
+ rm -rf doxygen *.gcda *.gcno lcov-result
if HAVE_SPLINT
lint:
- $(LINT) ${DEFS} ${INCLUDES} test1.c ${libpopt_la_SOURCES}
-endif HAVE_SPLINT
+ $(SPLINT) ${DEFS} ${INCLUDES} test1.c ${libpopt_la_SOURCES}
+
+popt.lcd: Makefile.am ${libpopt_la_SOURCES} ${include_HEADERS} ${noinst_HEADERS}
+ $(SPLINT) -dump $@ ${libpopt_la_SOURCES}
+endif
+if HAVE_MCCABE
mccabe:
$(MCCABE) $(libpopt_la_SOURCES) | sort -n -r | head -n 10
+endif
+
if DOXYGEN_ENABLE
doxygen: Doxyfile
rm -rf doxygen
mkdir -p doxygen
- doxygen
-endif DOXYGEN_ENABLE
+ $(DOXYGEN)
+endif
+if HAVE_LCOV
# run lcov from scratch, always
lcov-reset:
make lcov-run
@@ -98,10 +94,24 @@ lcov-run:
# generate report based on current coverage data
lcov-report:
- mkdir lcov
- lcov --directory . --capture --output-file lcov/lcov.info
- lcov -l lcov/lcov.info | grep -v "`cd $(top_srcdir) && pwd`" | cut -d: -f1 > lcov/remove
- lcov -r lcov/lcov.info `cat lcov/remove` > lcov/lcov.cleaned.info
- rm lcov/remove
- mv lcov/lcov.cleaned.info lcov/lcov.info
- genhtml -t "$(PACKAGE_STRING)" -o lcov lcov/lcov.info
+ rm -rf lcov-result
+ mkdir lcov-result
+ $(LCOV) --directory . --capture --output-file lcov-result/lcov.info
+ $(LCOV) -l lcov-result/lcov.info | grep -v "`cd $(top_srcdir) && pwd`" | cut -d: -f1 > lcov-result/remove
+ $(LCOV) -r lcov-result/lcov.info `cat lcov-result/remove` > lcov-result/lcov.cleaned.info
+ rm lcov-result/remove
+ mv lcov-result/lcov.cleaned.info lcov-result/lcov.info
+ genhtml -t "$(PACKAGE_STRING)" -o lcov lcov-result/lcov.info
+endif
+
+.PHONY: updatepo
+updatepo:
+ rsync -Lrtvz translationproject.org::tp/latest/popt/ po
+ po_dir=./po
+ LANG=C
+ ls "$po_dir"/*.po 2>/dev/null | sed 's|.*/||; s|\.po$||' > "$po_dir/LINGUAS"
+
+.PHONY: sources
+sources:
+ @echo $(libpopt_la_SOURCES:%=popt/%)
+