summaryrefslogtreecommitdiff
path: root/auto/Makefile.am
diff options
context:
space:
mode:
authorjbj <jbj>2010-02-17 19:43:48 +0000
committerjbj <jbj>2010-02-17 19:43:48 +0000
commitf81e72ee7df2206c4cbfb6a9faff4c759f292283 (patch)
tree6c6b5b96dfa90f1419b8e6324068ebdf7d468ae1 /auto/Makefile.am
parentce1c25689ba3096b082f040e6bd2519cfb7715df (diff)
downloadlibpopt-f81e72ee7df2206c4cbfb6a9faff4c759f292283.tar.gz
- make distcheck is now squeaky clean.
- permit VPATH builds. - add shallow tests using ISP/RAS api-sanity-autotest.pl.
Diffstat (limited to 'auto/Makefile.am')
-rw-r--r--auto/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/auto/Makefile.am b/auto/Makefile.am
new file mode 100644
index 0000000..95d9064
--- /dev/null
+++ b/auto/Makefile.am
@@ -0,0 +1,12 @@
+AUTOMAKE_OPTIONS = 1.4 foreign
+
+AUTOTEST = api-sanity-autotest.pl
+
+TDIRS = descriptors_storage header_compile_errors test_results tests
+
+clean-local:
+ rm -rf $(TDIRS)
+
+check-local:
+ -[ -d tests ] && ${AUTOTEST} -l popt -d popt.desc -clean
+ -${AUTOTEST} -l popt -d popt.desc -st popt.types -gen -build -run