summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjbj <jbj>2010-06-14 17:12:57 +0000
committerjbj <jbj>2010-06-14 17:12:57 +0000
commit178fc648b88b30287e7b3fb1d3dffd816012a7bd (patch)
treefacea08113d37b3570a3d3f026fd02777091dc10 /configure.ac
parent0e3aa0bd0b87ec28a06c980c9328c482f650eae8 (diff)
downloadlibpopt-178fc648b88b30287e7b3fb1d3dffd816012a7bd.tar.gz
- change error returns to assert failures for development.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index aed6155..29a10ea 100755
--- a/configure.ac
+++ b/configure.ac
@@ -22,10 +22,8 @@ AC_SUBST(LT_CURRENT, 0)
AC_SUBST(LT_REVISION, 0)
AC_SUBST(LT_AGE, 8)
-
CFLAGS="$CFLAGS -D_GNU_SOURCE -D_REENTRANT"
-
# Checks for programs.
AC_PROG_CC
AC_PROG_CC_STDC
@@ -91,11 +89,10 @@ AC_CHECK_PROG(HAVE_MCCABE,pmccabe,"yes","no" )
AM_CONDITIONAL([HAVE_MCCABE], test x$HAVE_MCCABE != xno )
-
# Checks for libraries.
# Checks for header files.
-AC_CHECK_HEADERS([fcntl.h float.h langinfo.h libintl.h limits.h stdint.h stdlib.h string.h sys/ioctl.h unistd.h wchar.h])
+AC_CHECK_HEADERS([assert.h fcntl.h float.h langinfo.h libintl.h limits.h sys/ioctl.h wchar.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_INLINE
@@ -134,8 +131,6 @@ AC_ARG_ENABLE([ld-version-script],
[ : ] )
AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
-
-
# Autofu for pkgconfig
# Define a (hope) portable Libs pkgconfig directive that
# - Don't harm if the default library search path include ${libdir}
@@ -167,7 +162,6 @@ case "${host}" in
esac
AC_SUBST([POPT_PKGCONFIG_LIBS],"$popt_pkgconfig_libs")
-
AC_CONFIG_FILES([Makefile Doxyfile popt.pc popt.spec po/Makefile.in
auto/Makefile auto/desc ])
AC_OUTPUT