summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authorJan-Michael Brummer <jan.brummer@tabos.org>2023-05-02 10:53:36 +0200
committerGitHub <noreply@github.com>2023-05-02 10:53:36 +0200
commitd159c5f40ff7e82354e45116d9b66b1f596d9320 (patch)
tree34506d9ee6c699444a170c6bba8c925c45407d3e /libproxy/CMakeLists.txt
parent8fec01ed4b95afc71bf7710bf5b736a5de03b343 (diff)
parent5272fb3d114f0d012871380bd429546c73f0226d (diff)
downloadlibproxy-git-d159c5f40ff7e82354e45116d9b66b1f596d9320.tar.gz
Merge pull request #201 from janbrummer/rewrite
Complete rewrite
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt23
1 files changed, 0 insertions, 23 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
deleted file mode 100644
index 0bd7148..0000000
--- a/libproxy/CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-### Project info
-project(libproxy)
-set_project_version(0 4 18)
-
-### Add a global compilation stuff
-if (WIN32)
- add_definitions(-D_CRT_SECURE_NO_WARNINGS=1)
-else(WIN32)
- add_definitions(-D_POSIX_C_SOURCE=200112L)
- set(CMAKE_CXX_FLAGS "-fvisibility=hidden ${CMAKE_CXX_FLAGS}")
-endif(WIN32)
-
-### Modules
-include(cmake/modules.cmk)
-
-### Dev files
-include(cmake/devfiles.cmk)
-
-### Main library
-include(cmake/libproxy.cmk)
-
-### Tests
-add_testdirectory(test)