summaryrefslogtreecommitdiff
path: root/src/backend/plugins/config-osx/meson.build
diff options
context:
space:
mode:
authorJan-Michael Brummer <jan.brummer@tabos.org>2023-03-30 07:39:53 +0200
committerJan-Michael Brummer <jan.brummer@tabos.org>2023-03-30 11:44:46 +0200
commitd1107667da6da04395ff72a78839cf07a2fe1aa9 (patch)
tree50f2b0718c47f87133b33d3e13a49c5c08c9631b /src/backend/plugins/config-osx/meson.build
parent3604dc5aa5d623740263dd077f5b7d209cf1d486 (diff)
downloadlibproxy-git-d1107667da6da04395ff72a78839cf07a2fe1aa9.tar.gz
Remove libpeas support
As we no longer have further dependencies like glib for accessing the standard linux configurations and the other are platform specific. Let's remove peas all together. Plugins are now built-in.
Diffstat (limited to 'src/backend/plugins/config-osx/meson.build')
-rw-r--r--src/backend/plugins/config-osx/meson.build39
1 files changed, 8 insertions, 31 deletions
diff --git a/src/backend/plugins/config-osx/meson.build b/src/backend/plugins/config-osx/meson.build
index eac98e8..f801d90 100644
--- a/src/backend/plugins/config-osx/meson.build
+++ b/src/backend/plugins/config-osx/meson.build
@@ -1,39 +1,16 @@
plugin_name = 'config-osx'
-if host_machine.system() == 'darwin'
+if get_option(plugin_name) and with_platform_darwin
-if get_option(plugin_name)
-
-plugin_src = [
- '@0@.c'.format(plugin_name),
+foundation_dep = dependency('Foundation')
+system_configuration_dep = dependency('SystemConfiguration')
+px_backend_deps += [
+ foundation_dep,
+ system_configuration_dep,
]
-plugin_data = [
- '@0@.plugin'.format(plugin_name),
+px_backend_sources += [
+ 'plugins/@0@/@0@.c'.format(plugin_name),
]
-plugin_lib = shared_module(
- plugin_name,
- plugin_src,
- include_directories: px_backend_inc,
- c_args: px_backend_c_args,
- dependencies: [px_backend_dep],
- install_dir: join_paths(px_plugins_dir, plugin_name),
- install: true,
- name_suffix: module_suffix
-)
-
-# Starting with Meson 0.64 this can be replaced with fs.copyfile
-custom_target(
- '@0@-data'.format(plugin_name),
- input: plugin_data,
- output: plugin_data,
- command: ['cp', '@INPUT@', '@OUTDIR@'],
- build_by_default: true,
- install_dir: join_paths(px_plugins_dir, plugin_name),
- install: true,
-)
-
-endif
-
endif