summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorJan-Michael Brummer <jan.brummer@tabos.org>2023-03-30 07:39:53 +0200
committerJan-Michael Brummer <jan.brummer@tabos.org>2023-03-30 11:44:46 +0200
commitd1107667da6da04395ff72a78839cf07a2fe1aa9 (patch)
tree50f2b0718c47f87133b33d3e13a49c5c08c9631b /tests/meson.build
parent3604dc5aa5d623740263dd077f5b7d209cf1d486 (diff)
downloadlibproxy-git-d1107667da6da04395ff72a78839cf07a2fe1aa9.tar.gz
Remove libpeas support
As we no longer have further dependencies like glib for accessing the standard linux configurations and the other are platform specific. Let's remove peas all together. Plugins are now built-in.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index b5ca084..4ae8e7d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -76,4 +76,28 @@ if get_option('tests')
env: [envs, 'XDG_CURRENT_DESKTOP=KDE'],
)
endif
+
+ if get_option('config-osx') and with_platform_darwin
+ config_osx_test = executable('test-config-osx',
+ ['config-osx-test.c', 'px-manager-helper.c'],
+ include_directories: px_backend_inc,
+ dependencies: [glib_dep, px_backend_dep],
+ )
+ test('Config OSX test',
+ config_osx_test,
+ env: [envs],
+ )
+ endif
+
+ if get_option('config-windows') and with_platform_windows
+ config_windows_test = executable('test-config-windows',
+ ['config-windows-test.c', 'px-manager-helper.c'],
+ include_directories: px_backend_inc,
+ dependencies: [glib_dep, px_backend_dep],
+ )
+ test('Config Windows test',
+ config_windows_test,
+ env: [envs],
+ )
+ endif
endif