summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 23a7e91..3fa6e5a 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -7,6 +7,16 @@ if get_option('tests')
test_cargs = ['-UG_DISABLE_ASSERT']
+ libproxy_test = executable('test-libproxy',
+ ['libproxy-test.c'],
+ include_directories: libproxy_inc,
+ dependencies: [libproxy_test_dep],
+ )
+ test('Libproxy test',
+ libproxy_test,
+ env: envs
+ )
+
if soup_dep.found()
px_manager_test = executable('test-px-manager',
['px-manager-test.c', 'px-manager-helper.c'],