summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-08 19:03:26 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-08 19:03:26 +0000
commit561f9cd12932be67275b9bbbf24951dfee5da43e (patch)
tree16447415202521df0625db96ad95176764cadc37 /libproxy/CMakeLists.txt
parent2a0d7f3e63d846774d4ba064c9f63f1b3a338f31 (diff)
downloadlibproxy-561f9cd12932be67275b9bbbf24951dfee5da43e.tar.gz
fix build on macosx
git-svn-id: http://libproxy.googlecode.com/svn/trunk@528 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index 26dfd6b..3493f1b 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -81,13 +81,13 @@ if(APPLE)
find_library(WEBKIT_LIBRARIES JavaScriptCore)
find_library(SC_LIBRARIES SystemConfiguration)
find_library(CF_LIBRARIES CoreFoundation)
- if(${WEBKIT_LIBRARIES})
+ if(NOT "${WEBKIT_LIBRARIES}" STREQUAL "")
set(WEBKIT_FOUND 1)
endif()
- if(${SC_LIBRARIES})
+ if(NOT "${SC_LIBRARIES}" STREQUAL "")
set(SC_FOUND 1)
endif()
- if(${CF_LIBRARIES})
+ if(NOT "${CF_LIBRARIES}" STREQUAL "")
set(CF_FOUND 1)
endif()
endif()
@@ -97,7 +97,7 @@ endif()
## Module definition
#
message("MODULES TO BUILD:")
-px_module(config_envvar "${UNIX}")
+px_module(config_envvar "${UNIX} AND NOT ${APPLE}")
px_module(config_gnome "${GNOME_FOUND}" ${X11_LIBRARIES})
px_module(config_kde4 "${KDE4_FOUND}" ${KDE4_LIBRARIES} ${X11_LIBRARIES})
px_module(config_macosx "${SC_FOUND}" ${SC_LIBRARIES} ${CF_LIBRARIES})