summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authordominique.leuenberger <dominique.leuenberger@c587cffe-e639-0410-9787-d7902ae8ed56>2010-03-06 21:31:31 +0000
committerdominique.leuenberger <dominique.leuenberger@c587cffe-e639-0410-9787-d7902ae8ed56>2010-03-06 21:31:31 +0000
commit5e3a78f766622bd6a6e78c02dd0b29542cc862fa (patch)
treeb402ecdf592a3c87ee216ad46befe08cb7328eb6 /libproxy/CMakeLists.txt
parent8b43a6fdcf054bd0e461ffb54168081c588ba534 (diff)
downloadlibproxy-5e3a78f766622bd6a6e78c02dd0b29542cc862fa.tar.gz
cmake: Add a Findlibproxy.cmake to our bundle.
This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings.cmake: Add a Findlibproxy.cmake to our bundle. This allows any cmake based package to simply invoke find_package(libproxy) to get all the needed settings. git-svn-id: http://libproxy.googlecode.com/svn/trunk@604 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index a6a1d03..a9f89fa 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -139,6 +139,12 @@ if(NOT WIN32 AND NOT APPLE)
install(FILES libproxy-1.0.pc DESTINATION ${libdir}/pkgconfig)
endif()
+# CMake Find helper
+if (NOT WIN32 AND NOT APPLE)
+ configure_file(Findlibproxy.cmake.in Findlibproxy.cmake @ONLY)
+ install(FILES Findlibproxy.cmake DESTINATION ${datadir}/cmake/Modules)
+endif()
+
# GNOME (gconf) helper
if(${GNOME_FOUND})
add_executable(pxgconf modules/pxgconf.cpp)