summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-10 02:10:08 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-10 02:10:08 +0000
commita13d7fb6d03ffd808ee6a4d4e65bb6f32e97eacb (patch)
treebb82187c87414a630069568a4b47e64f3c3b5d23 /libproxy/CMakeLists.txt
parent0074bcf1c408844cc2bb706c3ef4af78135b0e05 (diff)
downloadlibproxy-a13d7fb6d03ffd808ee6a4d4e65bb6f32e97eacb.tar.gz
fix mozjs detection
git-svn-id: http://libproxy.googlecode.com/svn/trunk@533 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index fb82f47..f78688f 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -53,11 +53,14 @@ if("${PKG_CONFIG_FOUND}")
px_check_modules(NM NetworkManager dbus-1)
px_check_modules(WEBKIT webkit-1.0)
px_check_modules(MOZJS xulrunner-js)
- if(NOT ${MOZJS_FOUND})
+ if(NOT MOZJS_FOUND)
+ unset(MOZJS_FOUND)
px_check_modules(MOZJS firefox-js)
- if(NOT ${MOZJS_FOUND})
+ if(NOT MOZJS_FOUND)
+ unset(MOZJS_FOUND)
px_check_modules(MOZJS mozilla-js)
- if(NOT ${MOZJS_FOUND})
+ if(NOT MOZJS_FOUND)
+ unset(MOZJS_FOUND)
px_check_modules(MOZJS seamonkey-js)
endif()
endif()