summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-20 16:11:40 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-20 16:11:40 +0000
commita83c265e215a9fa072e5cd3096ecb94d47466497 (patch)
treefe6de894ebf0c75b22f1831a0621aaa0781776c8 /libproxy/CMakeLists.txt
parent099020bc04d77a2db79e8d0648392d361d78d9a5 (diff)
downloadlibproxy-a83c265e215a9fa072e5cd3096ecb94d47466497.tar.gz
yet another set of build fixes for win32
git-svn-id: http://libproxy.googlecode.com/svn/trunk@485 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index 7dc2ed6..fa3af13 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -1,5 +1,9 @@
set(lpSOURCES config_file.cpp dl_module.cpp module_manager.cpp module_types.cpp pac.cpp proxy.cpp url.cpp)
-set(lpLIBRARIES m pthread dl)
+if (UNIX OR APPLE)
+ set(lpLIBRARIES m pthread dl)
+else()
+ set(lpLIBRARIES "")
+endif()
set(BUILTIN_MODULES "")
### Misc files