summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-20 00:01:16 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-20 00:01:16 +0000
commitac51c595e812e5fd352ba16c6f8ebc01d2237af6 (patch)
tree2df15bf66013d25fbd8c7a8cd3031ae1b6964550 /libproxy/CMakeLists.txt
parent0b1d0e73c686b78c70f5f67ec9c4d3c67e600d0f (diff)
downloadlibproxy-ac51c595e812e5fd352ba16c6f8ebc01d2237af6.tar.gz
move the builtins array into the module_manager (from the separate header)
git-svn-id: http://libproxy.googlecode.com/svn/trunk@483 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index 8254d57..7dc2ed6 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -112,10 +112,10 @@ px_module(wpad_dnsdevolution 1)
message("")
### Main library
-configure_file(builtin_modules.hpp.in builtin_modules.hpp @ONLY)
add_library(libproxy SHARED ${lpSOURCES})
target_link_libraries(libproxy ${lpLIBRARIES})
set_property(SOURCE proxy.cpp PROPERTY COMPILE_DEFINITIONS SYSCONFDIR="/etc/";MODULEDIR="${moduledir}")
+set_property(SOURCE module_manager.cpp PROPERTY COMPILE_DEFINITIONS BUILTIN_MODULES=${BUILTIN_MODULES})
set_target_properties(libproxy PROPERTIES PREFIX "" COMPILE_FLAGS -g VERSION 0 SOVERSION 0.0.0)
install(TARGETS libproxy DESTINATION ${rlibdir})
install(FILES proxy.h DESTINATION ${rincludedir})