summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-04 03:07:56 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-02-04 03:07:56 +0000
commitee59072c05c9a94556c3470a5a60571b84105781 (patch)
tree5873131ed3b96f8bba4476c61517214b846e9d69 /libproxy/CMakeLists.txt
parent8ed9116d8c093fb84d601ef4e2b906281fa2fe83 (diff)
downloadlibproxy-ee59072c05c9a94556c3470a5a60571b84105781.tar.gz
config_w32reg actually works now, including ignore support; other misc win32 fixes
git-svn-id: http://libproxy.googlecode.com/svn/trunk@512 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index 6c32e35..cdc12fb 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -5,6 +5,11 @@ if(WIN32)
else()
target_link_libraries(libproxy m pthread dl)
endif()
+file(TO_NATIVE_PATH ${moduledir} moduledir)
+if(WIN32)
+ string(REGEX REPLACE "\\\\" "\\\\\\\\" moduledir ${moduledir})
+endif()
+
set_property(SOURCE proxy.cpp PROPERTY COMPILE_DEFINITIONS SYSCONFDIR="/etc/";MODULEDIR="${moduledir}")
set_target_properties(libproxy PROPERTIES PREFIX "" VERSION 0 SOVERSION 0.0.0)
install(TARGETS libproxy DESTINATION ${rlibdir})
@@ -99,7 +104,7 @@ px_module(config_macosx "${SC_FOUND}" ${SC_LIBRARIES} ${CF_LIBRAR
px_module(config_w32reg "${WIN32}")
px_module(config_wpad 1)
px_module(ignore_domain 1)
-px_module(ignore_hostname "${APPLE}")
+px_module(ignore_hostname 1)
px_module(ignore_ip 1)
px_module(network_networkmanager "${NM_FOUND}" ${NM_LIBRARIES})
px_module(pacrunner_mozjs "${MOZJS_FOUND}" ${MOZJS_LIBRARIES})
@@ -109,8 +114,10 @@ message("")
### Misc files
# PkgConfig file
-configure_file(libproxy-1.0.pc.in libproxy-1.0.pc @ONLY)
-install(FILES libproxy-1.0.pc DESTINATION ${libdir}/pkgconfig)
+if(NOT ${WIN32})
+ configure_file(libproxy-1.0.pc.in libproxy-1.0.pc @ONLY)
+ install(FILES libproxy-1.0.pc DESTINATION ${libdir}/pkgconfig)
+endif()
# GNOME (gconf) helper
if(${GNOME_FOUND})