summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2021-09-09 23:51:46 +0200
committerIñigo Martínez <inigomartinez@gmail.com>2021-09-13 11:05:44 +0200
commit3831932228c2271d722ac9785f2dc4a6c8d88686 (patch)
tree9340fb24d18f35b3fae97ccb128641dbce055267 /meson.build
parent34cc1b10fef443fc8e1fe80adfc819f2d262308d (diff)
downloadlibqmi-3831932228c2271d722ac9785f2dc4a6c8d88686.tar.gz
build: Make use of dictionaries
meson gained the dictionaries as builtin objects[0] that can be modified with the addition operator[1] and can be useful when setting configuration or even environment values[2]. The individual object creation has been replaced by dictionaries when possible. [0] http://mesonbuild.com/Release-notes-for-0-47-0.html#new-builtin-object-type-dictionary [1] https://mesonbuild.com/Release-notes-for-0-48-0.html#dictionary-addition [2] https://mesonbuild.com/Release-notes-for-0-52-0.html#support-taking-environment-values-from-a-dictionary
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index bbe753de..9cee511a 100644
--- a/meson.build
+++ b/meson.build
@@ -225,10 +225,11 @@ endif
random_number = qmi_minor_version + meson.version().split('.').get(1).to_int()
-test_env = environment()
-test_env.set('G_DEBUG', 'gc-friendly')
-test_env.set('MALLOC_CHECK_', '2')
-test_env.set('MALLOC_PERTURB_', (random_number % 256).to_string())
+test_env = {
+ 'G_DEBUG': 'gc-friendly',
+ 'MALLOC_CHECK_': '2',
+ 'MALLOC_PERTURB_': (random_number % 256).to_string(),
+}
subdir('src')
subdir('utils')