summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@aleksander.es>2021-08-06 10:32:22 +0200
committerAleksander Morgado <aleksander@aleksander.es>2021-08-06 10:35:32 +0200
commitbfb066419f288764edbade1e27e93a5dda59a5f4 (patch)
tree92d047c7c43b8ed911b00e5bdcac4ffef85e209c /meson.build
parent00212716ee5eefd57e4df5a6bc811d5a30fde0d4 (diff)
downloadlibqmi-bfb066419f288764edbade1e27e93a5dda59a5f4.tar.gz
build,meson: fix introspection option
Using -Dintrospection=false would actually not disable it. There is no longer an "auto" option for the introspection support, it will be either enabled or disabled depending on what the user asks for (default enabled).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b25bca57..d28e5601 100644
--- a/meson.build
+++ b/meson.build
@@ -218,7 +218,10 @@ version_conf.set10('QMI_QRTR_SUPPORTED', enable_qrtr)
version_conf.set10('QMI_RMNET_SUPPORTED', enable_rmnet)
# introspection support
-enable_gir = dependency('gobject-introspection-1.0', version: '>= 0.9.6', required: get_option('introspection')).found()
+enable_gir = get_option('introspection')
+if enable_gir
+ dependency('gobject-introspection-1.0', version: '>= 0.9.6')
+endif
random_number = qmi_minor_version + meson.version().split('.').get(1).to_int()