summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid King <amigadave@amigadave.com>2022-05-13 10:07:05 +0100
committerDavid King <amigadave@amigadave.com>2022-05-13 10:07:05 +0100
commit192cf4815a47b6bdd39938667c8452bb4c875eb2 (patch)
tree85b445a79104ee734d51b262b122673a13dc6358 /configure.ac
parenta380a1b45c970fb3861f5555f08431352c2010bf (diff)
downloadlibrsvg-192cf4815a47b6bdd39938667c8452bb4c875eb2.tar.gz
build: Fix gtk-doc check
https://gitlab.gnome.org/GNOME/librsvg/-/issues/866 Part-of: <https://gitlab.gnome.org/GNOME/librsvg/-/merge_requests/701>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c3b1ff34..2d16e6d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,11 +129,11 @@ AC_ARG_ENABLE([gtk-doc],
AS_IF([test "x$enable_gtk_doc" != xno],
[AC_CHECK_TOOL(GI_DOCGEN, [gi-docgen], [no])
- AS_IF([test "x$GI_DOCGEN" = no],
+ AS_IF([test "x$GI_DOCGEN" = xno],
[AS_CASE(["$enable_gtk_doc"],
[yes], [AC_MSG_ERROR([gi-docgen not found - cannot build docs])],
[auto], [AC_MSG_WARN([gi-docgen not found - not building docs])])
- enable_gtk_doc=no]
+ enable_gtk_doc=no],
[enable_gtk_doc=yes])])
AM_CONDITIONAL(ENABLE_GTK_DOC, [test "x$enable_gtk_doc" = xyes])