summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63b10627..c9666757 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,11 @@ PKG_PROG_PKG_CONFIG
LT_INIT([win32-dll])
LT_LIB_M
+# Check if -ldl is needed to use dlopen()
+AC_CHECK_FUNC(dlopen, [],
+ [AC_CHECK_LIB(dl, dlopen, [DLOPEN_LIBS=-ldl])])
+AC_SUBST(DLOPEN_LIBS)
+
dnl ===========================================================================
AC_CHECK_PROG(CARGO, [cargo], [yes], [no])