summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDonovan Baarda <abo@minkirri.apana.org.au>2020-06-02 00:10:43 +1000
committerDonovan Baarda <abo@minkirri.apana.org.au>2020-06-02 00:10:43 +1000
commitd00af8bc80abb329f5e6d370aac9ded5bd7a5d55 (patch)
tree82bfea1bccab1b74cb776b284f0b92a71dcab3b2 /CMakeLists.txt
parentf59337ee71fdc9f8261d6fcc1d1437e89ce37655 (diff)
downloadlibrsync-d00af8bc80abb329f5e6d370aac9ded5bd7a5d55.tar.gz
Pass `-C Debug` to ctest instead of `--config Debug` to cmake.
It seems passing `--config Debug` to cmake in .travis.yml didn't work. Instead we need to pass `-C Debug` to ctest in CMakeLists.txt to make it work on Windows.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49b50a1..b341901 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -297,7 +297,7 @@ if (BUILD_RDIFF)
else (BUILD_RDIFF)
set(LAST_TARGET rsync)
endif (BUILD_RDIFF)
-add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
+add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} -C Debug)
add_dependencies(check ${LAST_TARGET}
isprefix_test
netint_test