summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-05-22 16:28:17 -0400
committerPaul Moore <pmoore@redhat.com>2014-05-22 16:28:17 -0400
commit10383c95be9beabf76d22e5e0ed62f2a4789dae9 (patch)
tree41996ce11522d841159bc6f43829446066dd1ac4 /Makefile.am
parent8139f5f7b71044fe21969e944d162e9e98c6e5eb (diff)
downloadlibseccomp-10383c95be9beabf76d22e5e0ed62f2a4789dae9.tar.gz
tests: create a simple program to test the internal syscall tables
This patch adds a dead simple, and a bit hack-ish, little program that checks the internal syscall tables for consistency across the different supported architectures. We also tie this test into the autotools test infrastructure. This should be of particular importance when adding or updating architectures. This patch also fixed some automake/libtool problems which were causing us to double-build some objects under src/. Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b70e4fa..4709b78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,7 @@ AM_MAKEFLAGS_ = ${AM_MAKEFLAGS_0}
AM_MAKEFLAGS = ${AM_MAKEFLAGS_@AM_V@}
check-build: all
+ ${MAKE} ${AM_MAKEFLAGS} -C src check-build
${MAKE} ${AM_MAKEFLAGS} -C tests check-build
check-syntax: