summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2017-03-01 17:24:12 -0500
committerPaul Moore <paul@paul-moore.com>2017-03-01 17:24:12 -0500
commit30be87efde4e0853e351e304c46c14c019a3d238 (patch)
treeac056cd7399e852c25864c01e09ea98f898b949c /Makefile.am
parentfda1f0741fb55d6951f312f310cc159e17555788 (diff)
downloadlibseccomp-30be87efde4e0853e351e304c46c14c019a3d238.tar.gz
build: create an easy to use test coverage make target
Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 29ee2ec..48078e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,19 @@ check-build: all
check-syntax:
@./tools/check-syntax
+if CODE_COVERAGE_ENABLED
check-code-coverage: check-build
${MAKE} ${AM_MAKEFLAGS} -C tests check-code-coverage
+endif
+
+if CODE_COVERAGE_ENABLED
+test-code-coverage: check-build
+ ${MAKE} ${AM_MAKEFLAGS} -C src check-code-coverage
+ LIBSECCOMP_TSTCFG_TYPE=basic \
+ ${MAKE} ${AM_MAKEFLAGS} check-code-coverage
+ LIBSECCOMP_TSTCFG_TYPE=bpf-sim \
+ ${MAKE} ${AM_MAKEFLAGS} check-code-coverage
+endif
if COVERITY
coverity-build: clean