summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2018-05-10 19:25:34 -0400
committerPaul Moore <paul@paul-moore.com>2018-05-10 19:25:34 -0400
commit8ad3638ea9023c3948976dfadebd1554380a31c9 (patch)
tree7c7cf1feee88e14413ac4b6173ab67da9bb5a1f3 /Makefile.am
parenta9745ef2c36eba7828ef466aaa9eaafea281d6f6 (diff)
downloadlibseccomp-8ad3638ea9023c3948976dfadebd1554380a31c9.tar.gz
build: enable distcheck'ing for the python code
I'm not particularly proud of the seccomp.pyx hack, but it works, and enabling the python bindings during the distcheck is definitely the "Greater Good". Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d476037..b69cec5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,9 @@ AM_MAKEFLAGS_1 =
AM_MAKEFLAGS_ = ${AM_MAKEFLAGS_0}
AM_MAKEFLAGS = ${AM_MAKEFLAGS_@AM_V@}
+# enable python during distcheck
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-python
+
check-build: all
${MAKE} ${AM_MAKEFLAGS} -C src check-build
${MAKE} ${AM_MAKEFLAGS} -C tests check-build