summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-08-21 12:05:08 -0400
committerPaul Moore <pmoore@redhat.com>2014-08-21 14:55:12 -0400
commitb61f4065f76f3868a6c597f37932de2e65e4fa97 (patch)
treedeea4648398160c5273d77bd512c9469363b4d09 /Makefile.am
parent76eaa8a1e41fe8295142811b74de53ea2474e79e (diff)
downloadlibseccomp-b61f4065f76f3868a6c597f37932de2e65e4fa97.tar.gz
build: add support for Coverity scanning
Thanks to the folks at Coverity for supporting Open Source projects such as this one. Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4709b78..7fe0787 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,3 +34,20 @@ check-build: all
check-syntax:
@./tools/check-syntax
+
+if COVERITY
+coverity-build: clean
+ cov-build --dir cov-int ${MAKE} ${AM_MAKEFLAGS} check-build
+endif
+
+if COVERITY
+coverity-tarball: coverity-build
+ @git rev-parse HEAD &> /dev/null && \
+ rev=$$(git rev-parse HEAD | cut -c1-8) || \
+ rev=$$(date --iso-8601=date); \
+ tar czf libseccomp-coverity_$$rev.tar.gz cov-int; \
+ ls -l libseccomp-coverity_$$rev.tar.gz
+endif
+
+clean-local:
+ ${RM} -rf cov-int libseccomp-coverity_*.tar.gz