summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-05-07 12:05:59 -0400
committerPaul Moore <pmoore@redhat.com>2014-05-07 12:05:59 -0400
commite8a449fb5b87ba0479524b661fe962a5d977d400 (patch)
tree477d8c82acf2beeca1224b3a473967ac13b83c8c /Makefile.am
parent430419e312ceb7c3ca1255b97c8b4ec0151e8bb3 (diff)
downloadlibseccomp-e8a449fb5b87ba0479524b661fe962a5d977d400.tar.gz
build: create a 'check-build' target
Sometimes it is helpful to build the test without executing them, add a new target, 'check-build' to do just that. Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 88b6538..b70e4fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,5 +28,8 @@ AM_MAKEFLAGS_1 =
AM_MAKEFLAGS_ = ${AM_MAKEFLAGS_0}
AM_MAKEFLAGS = ${AM_MAKEFLAGS_@AM_V@}
+check-build: all
+ ${MAKE} ${AM_MAKEFLAGS} -C tests check-build
+
check-syntax:
@./tools/check-syntax