summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-08-22 13:01:19 -0400
committerPaul Moore <pmoore@redhat.com>2014-08-29 14:42:08 -0400
commitf6c219703e3e654e60bb341ab4de362a133fdba6 (patch)
tree57832151acc5eacb7853e68bad54503de97ee34b /Makefile.am
parent956fff9c15cec79525dd496d0561561eee6ca44c (diff)
downloadlibseccomp-f6c219703e3e654e60bb341ab4de362a133fdba6.tar.gz
all: fix a number of small bugs found by Coverity
Also display the build revision to make things easier when submitting builds for scanning. Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fe0787..71fde48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,10 +42,15 @@ endif
if COVERITY
coverity-tarball: coverity-build
- @git rev-parse HEAD &> /dev/null && \
- rev=$$(git rev-parse HEAD | cut -c1-8) || \
- rev=$$(date --iso-8601=date); \
+ @if git rev-parse HEAD &> /dev/null; then \
+ rev_full=$$(git rev-parse HEAD); \
+ rev=$$(echo $$rev_full | cut -c1-8); \
+ else \
+ rev_full=$$(date --iso-8601=date); \
+ rev=$$rev_full; \
+ fi; \
tar czf libseccomp-coverity_$$rev.tar.gz cov-int; \
+ echo " HEAD revision: $$rev_full"; \
ls -l libseccomp-coverity_$$rev.tar.gz
endif