summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-04-23 15:55:43 -0400
committerPaul Moore <pmoore@redhat.com>2014-05-01 14:15:02 -0400
commit1f4013fe223960231f614431eef13b82c75f85d6 (patch)
tree922061851ed8e69d55c185f12a380d69a569e9a8 /configure.ac
parent3b82469ed95797372d9ec5515cf1518ac4f0b5c8 (diff)
downloadlibseccomp-1f4013fe223960231f614431eef13b82c75f85d6.tar.gz
build: cleanup and document the remaining autoconf bits
Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2444e25..dcd9a9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,16 +4,34 @@ dnl libseccomp defines
dnl ####
AC_INIT([libseccomp], [0.0.0])
+dnl ####
+dnl autoconf configuration
+dnl ####
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([configure.h])
AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE([-Wall foreign subdir-objects tar-pax no-dist-gzip dist-xz serial-tests])
+
+dnl ####
+dnl automake configuration
+dnl ####
+AM_INIT_AUTOMAKE([-Wall foreign subdir-objects tar-pax serial-tests])
+
+dnl ####
+dnl build tools
+dnl ####
AC_PROG_CC
AM_PROG_CC_C_O
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-AC_DISABLE_STATIC
-LT_INIT
+
+dnl ####
+dnl libtool configuration
+dnl ####
+LT_INIT([shared disable-static pic-only])
+
+dnl ####
+dnl enable silent builds by default
+dnl ####
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
dnl ####
dnl build flags