summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2020-08-02 09:57:39 -0400
committerPaul Moore <paul@paul-moore.com>2020-08-04 09:43:54 -0400
commit5cd9059618a0810ee47c21e6b44c5a876b75e23d (patch)
tree3a84d5f8332272340c6ab753ef81be68ef225c80 /configure.ac
parent2366f6380198c7af23d145a153ccaa9ba37f9db1 (diff)
downloadlibseccomp-5cd9059618a0810ee47c21e6b44c5a876b75e23d.tar.gz
build: undefine "mips" to prevent build problems for MIPS targets
It turns out that the MIPS GCC compiler defines a "mips" cpp macro which was resulting in build failures on MIPS so we need to undefine the "mips" macro during build. As this should be safe to do in all architectures, just add it to the compiler flags by default. This was reported in the following GH issue: * https://github.com/seccomp/libseccomp/issues/274 Reported-by: Rongwei Zhang <pudh4418@gmail.com> Suggested-by: Rongwei Zhang <pudh4418@gmail.com> Acked-by: Tom Hromatka <tom.hromatka@oracle.com> Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40d9dcb..3e87734 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,9 +65,11 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
dnl ####
dnl build flags
+dnl NOTE: the '-Umips' is here because MIPS GCC compilers "helpfully" define it
+dnl for us which wreaks havoc on the build
dnl ####
AM_CPPFLAGS="-I\${top_srcdir}/include -I\${top_builddir}/include"
-AM_CFLAGS="-Wall"
+AM_CFLAGS="-Wall -Umips"
AM_LDFLAGS="-Wl,-z -Wl,relro"
AC_SUBST([AM_CPPFLAGS])
AC_SUBST([AM_CFLAGS])