summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGiuseppe Scrivano <gscrivan@redhat.com>2020-01-23 17:01:39 +0100
committerPaul Moore <paul@paul-moore.com>2020-03-23 11:14:35 -0400
commit9b129c41ac1f43d373742697aa2faf6040b9dfab (patch)
tree25c69d113e954473adb7b5209c76b67773a383e9 /configure.ac
parentf5b3166d6126f4a45b59d6af6780b5e00a0e9867 (diff)
downloadlibseccomp-9b129c41ac1f43d373742697aa2faf6040b9dfab.tar.gz
arch: use gperf to generate a perfact hash to lookup syscall names
This patch significantly improves the performance of seccomp_syscall_resolve_name since it replaces the expensive strcmp for each syscall in the database, with a lookup table. The complexity for syscall_resolve_num is not changed and it uses the linear search, that is anyway less expensive than seccomp_syscall_resolve_name as it uses an index for comparison instead of doing a string comparison. On my machine, calling 1000 seccomp_syscall_resolve_name_arch and seccomp_syscall_resolve_num_arch over the entire syscalls DB passed from ~0.45 sec to ~0.06s. PM: After talking with Giuseppe I made a number of additional changes, some substantial, the highlights include: * various style tweaks * .gitignore fixes * fixed subject line, tweaked the description * dropped the arch-syscall-validate changes as they were masking other problems * extracted the syscalls.csv and file deletions to other patches to keep this one more focused * fixed the x86, x32, arm, all the MIPS ABIs, s390, and s390x ABIs as the syscall offsets were not properly incorporated into this change * cleaned up the ABI specific headers * cleaned up generate_syscalls_perf.sh and renamed to arch-gperf-generate * fixed problems with automake's file packaging Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com> Reviewed-by: Tom Hromatka <tom.hromatka@oracle.com> [PM: see notes in the "PM" section above] Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e8b77f2..40d9dcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,11 @@ AC_DEFINE_UNQUOTED([ENABLE_PYTHON],
[$(test "$enable_python" = yes && echo 1 || echo 0)],
[Python bindings build flag.])
+AC_CHECK_TOOL(GPERF, gperf)
+if test -z "$GPERF"; then
+ AC_MSG_ERROR([please install gperf])
+fi
+
dnl ####
dnl coverity checks
dnl ####