summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2016-02-19 11:39:00 -0500
committerPaul Moore <paul@paul-moore.com>2016-02-22 17:07:07 -0500
commita1f144a9a28aa1b831f7d3f481fb3e0e5e3de3aa (patch)
tree6ede7b5cf09d7bca92014eba186db8939dd0d4a2 /configure.ac
parent4d29f58649cbd1fbf13e95aeac5208eb5638b436 (diff)
downloadlibseccomp-a1f144a9a28aa1b831f7d3f481fb3e0e5e3de3aa.tar.gz
all: use the seccomp() syscall whenever possible for tested ABIs
The seccomp() syscall was first added in Linux 3.17 so most systems should now support this syscall. Most importantly, the use of the seccomp() syscall enabled the thread sync functionality which isn't possible with prctl(); although callers still need to enable the flag per-filter as the thread sync default is disabled. This patch also unified the return values of the sys_chk_*() functions. Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 75f721e..3d8596e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,12 +89,6 @@ AC_SUBST([VERSION_MINOR])
AC_SUBST([VERSION_MICRO])
dnl ####
-dnl function checks
-dnl ####
-dnl # NOTE: keep this disabled until we can test on a released 3.17 kernel
-dnl AC_CHECK_FUNCS(seccomp)
-
-dnl ####
dnl cython checks
dnl ####
AC_CHECK_PROG(have_cython, cython, "yes", "no")