summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2017-02-06 17:08:15 -0500
committerPaul Moore <paul@paul-moore.com>2017-02-06 18:40:02 -0500
commita697763953670b7d9ce3375fe2d3c6fe87fb076c (patch)
tree8c35973cd5a1491dfac23ff50e12aed7d1d77936 /configure.ac
parenteb78d651177aea5812a2757e72326388954fe1ec (diff)
downloadlibseccomp-a697763953670b7d9ce3375fe2d3c6fe87fb076c.tar.gz
build: add basic code coverage support
Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d8596e..c593caf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,6 +125,12 @@ AC_CHECK_PROG(have_coverity, cov-build, "yes", "no")
AM_CONDITIONAL(COVERITY, test "$have_coverity" = yes)
dnl ####
+dnl code coverage checks
+dnl -> https://www.gnu.org/software/autoconf-archive/ax_code_coverage.html
+dnl ####
+AX_CODE_COVERAGE
+
+dnl ####
dnl version dependent files
dnl ####
AC_CONFIG_FILES([