summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-08-21 12:05:08 -0400
committerPaul Moore <pmoore@redhat.com>2014-08-21 14:55:12 -0400
commitb61f4065f76f3868a6c597f37932de2e65e4fa97 (patch)
treedeea4648398160c5273d77bd512c9469363b4d09 /configure.ac
parent76eaa8a1e41fe8295142811b74de53ea2474e79e (diff)
downloadlibseccomp-b61f4065f76f3868a6c597f37932de2e65e4fa97.tar.gz
build: add support for Coverity scanning
Thanks to the folks at Coverity for supporting Open Source projects such as this one. Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8cdf4e5..59044e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,12 @@ AC_DEFINE_UNQUOTED([ENABLE_PYTHON],
[Python bindings build flag.])
dnl ####
+dnl coverity checks
+dnl ####
+AC_CHECK_PROG(have_coverity, cov-build, "yes", "no")
+AM_CONDITIONAL(COVERITY, test "$have_coverity" = yes)
+
+dnl ####
dnl version dependent files
dnl ####
AC_CONFIG_FILES([