summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2019-05-01 19:29:24 -0400
committerPaul Moore <paul@paul-moore.com>2019-05-01 20:01:42 -0400
commitd390edad9a8540c2e2dd0b12732cc8dd3fe1cc69 (patch)
tree022e98be8d97834d0c84b00e231a79725bdb1a5b /configure.ac
parent3570b5cf9acbd1711d417e08ec608eea7b83d416 (diff)
downloadlibseccomp-d390edad9a8540c2e2dd0b12732cc8dd3fe1cc69.tar.gz
python: use Cython language "3str"
Set the Cython language level to "3str" which is described in the Cython 0.29 changelog: "A new language level name 3str was added that mostly corresponds to language level 3, but keeps unprefixed string literals as type ‘str’ in both Py2 and Py3, and the builtin ‘str’ type unchanged. This will become the default in the next Cython release and is meant to help user code a) transition more easily to this new default and b) migrate to Python 3 source code semantics without making support for Python 2.x difficult." Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 34746a5..2ae6b2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,8 +109,8 @@ AC_ARG_ENABLE([python],
[build the python bindings, requires cython])])
AS_IF([test "$enable_python" = yes], [
# cython version check
- AS_IF([test "$CYTHON_VER_MAJ" -eq 0 -a "$CYTHON_VER_MIN" -lt 16], [
- AC_MSG_ERROR([python bindings require cython 0.16 or higher])
+ AS_IF([test "$CYTHON_VER_MAJ" -eq 0 -a "$CYTHON_VER_MIN" -lt 29], [
+ AC_MSG_ERROR([python bindings require cython 0.29 or higher])
])
AM_PATH_PYTHON
])